てきとう

ワーワーゆうとります

最新版が入れられないよー

yumで入れると6.2.8、でも最新版は6.6.9、そしたら最新版が入れたいじゃないか


というわけでyumで一度インストールしたけど削除

yum remove ImageMagick-devel


いざrpm
rpmでインストールしたい。google先生で検索しながらやってみる。大体の流れはこんな感じだった。

  • ImageMagickののソースをDL
  • jasper-libs、jasper-develをインストール
  • djvulibre-develのインストール
  • あと色々必要
    • install bzip2-devel
    • freetype-devel
    • libjpeg-devel
    • libpng-devel
    • libtiff-devel
    • giflib-devel
    • zlib-devel
    • perl-devel
    • ghostscript-devel
    • djvulibre-devel
    • libwmf-devel
    • jasper-devel
    • libtool-ltdl-devel
    • libX11-devel
    • libXext-devel
    • libXt-devel
    • lcms-devel
    • libxml2-devel
    • librsvg2-devel
    • rpm-build
  • そしてrpmをビルド


いない
yumからdjvulibre-develをもってきてね、と、どのサイトにも記載されている。でも、いないのだ。

[hogehoge@hoge src]# sudo yum --enablerepo=rpmforge install djvulibre-devel
Loaded plugins: fastestmirror


Error getting repository data for rpmforge, repository not found

Oh....

いない

[hogehoge@hoge src]# yum search djvulibre-devel
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * extras: ftp.riken.jp
 * updates: ftp.riken.jp
 * base: ftp.riken.jp
 * addons: ftp.riken.jp
Warning: No matches found for: djvulibre-devel
No Matches found

しょうがないのでRPM Searchで探したら、たくさんいたのでそれっぽいのを連れて帰る。
そしてインストールしようとしたら色々足りない→探す→入れよう→足りないの無限ループに。



やめよう



今度また気が向いたら最新版インストールにチャレンジします。

広告を非表示にする