読者です 読者をやめる 読者になる 読者になる

てきとう

ワーワーゆうとります

php複数バージョン地獄

PHPは以下のバージョンが入っています。

  • 4.9
  • 5.1
  • 5.2
  • 5.3


普段使いのPHPは5.2

# php -v
version 5.2.11

mysql_pdoを使いたいんだけど、入ってなかったのでリコンパイルでもしよう。
PHP5.2はソースをwgetしてコンパイルしたものだったはずなので
今までwgetしてきたファイルは/usr/local/srcにあるから、確認だ。

# ls /usr/local/src
php-4.4.9 php-5.3.5

あれ?


yumかな?

# yum list installed | grep php
php.i386                              5.1.6-27.el5_5.3                 installed
php-cli.i386                          5.1.6-27.el5_5.3                 installed
php-common.i386                       5.1.6-27.el5_5.3                 installed
php-ldap.i386                         5.1.6-27.el5_5.3                 installed

あれ??


どこいったの…?(´・_・`)


しょうがないのでPHPの5.2.11をwgetしてきて解凍してコンパイルしてみましたら、問題なくできました。pdoが使えるよ。やったね。
それにしてもどこに行ったんでしょう。圧縮ファイルと間違えて消したのかなー。いやだなーこわいなー。

広告を非表示にする